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PART 1:

74ACT299 GENERAL DESCRIPTION

DATASHEET

ANALYSIS

8-bit universal shift/storage register with tristate outputs.

Pin description

Pin Names Description Y
cP Clock Pulse Input so B Vee
DS, Serial Data Input for Right Shift V081 .
\0E2 — 3 18— DS7
DS~ Serial Data Input for Left Shift
s —4 @ 17 a7
Sp. S4 Mode Select Inputs o4 — 5 &’ 16— vo7
MR Asynchronous Master Reset o2 — 6 5 15— UOS
OE,, OE, 3-STATE Output Enable Inputs o — 7 5, 14— 103
1/0g—1/07 Parallel Data Inputs or @ —8 &= 13- o1
3-STATE Parallel Outputs wWR 8 2= cp
) GND —{10 11— DSO
Qop, Q7 Serial Outputs

Logic diagram

CPWR SO S1 \OE1 \OE2
r 1 L P
| Control |

L

oo wo1 o2
Truth table
Inputs Response
MR| S, | S, |cCP

L | X | X | X [Asynchronous Reset; Q;—Q; = LOW
H | H | H |-~ |Parallel Load; /O, - Q,
H | L | H |-~ |Shift Right; DSy — Qg, Qg — Qq, etc.
H | H | L [-—|Shift Left, DS; = Q7, Q; — Qg, etc.
H|L]|L/|[ X |Hod

H = HIGH Voltage Level

L = LOW Voltage Level

X = Immaterial

—~ = LOW-to-HIGH Transition

Woe Wo7

=  Four modes of operation controlled
by (51, 50)
o hold (store)
o shift left
o shift right
o load data
= Asynchronous reset controlled by MR
(active on low)
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DC Electrical Characteristics (ACT)

Vee Tp=25C Tp=—40Cto+85C
Symbol Parameter Units Conditions
v) Typ Guaranteed Limits
Vi Minimum HIGH Level 4.5 1.5 2.0 2.0 v Vour =01V
Input Voltage 55 1.5 2.0 2.0 orVee - 0.1V
Vi Maximum LOW Level 3.0 1.5 0.8 0.8 i Vour =01V
Input Voltage 45 1.5 0.8 0.8 orVee — 0.1V
Vaou Minimum HIGH Level 4.5 4.49 4.4 4.4
\' |OUT =-50 uA
55 5.49 54 54
Vin=ViLorViy
45 0.0001 3.86 3.76 v loy =-24 mA
55 4.86 476 loy =—24 mA (Note 5)
VoL Maximum LOW Level 4.5 0.001 01 0.1
v louT =50 nA
Output Voltage &b 0.001 0.1 0.1
Vin=ViLorViy
45 6 0.44 v lor= 24 mA
55 0.44 loL= 24 mA (Note 5)
I Maximum Input Leakage Current 5.5 + +:4:0 uA V|, =Vee, GND
lceT Maximum Ige/Input 5.5 0.6 1.5 mA |V =Vgo -2.1V
loLp Minimum Dynamic 5.5 75 mA  |VoLp = 1.65V Max
lonD Qutput Current (Note &) 55 —75 mA | Vpyp = 3.85V Min
e Maximum Quiescent Supply Current 5.5 4.0 40.0 UA Wiy =Vero or GND
lozT Maximum /O VI(OE) =V, V4
Leakage Current 55 +0.3 +3.0 LA V| =Vee, GND
Vo =Vee, GND
Note 5: All outputs loaded; thresholds on input associated with output under test.
Note 6: Maximum test duration 2.0 ms, one output loaded at a time.
Recommended Operating
Conditions
Supply Voltage (Vo)
(Unless Otherwise Specified)
'AC 2.0Vto 6.0V
'ACT 4.5V to 5.0V
Input Voltage (V) 0V toVee
Output Voltage (Vo) 0VtoVee

Operating Temperature (Ta)
74AC/ACT
54AC/ACT
Minimum Input Edge Rate (AV/At)
'AC Devices
VN from 30% to 70% of Voo
Voc @ 3.3V, 4.5V, 55V
Minimum Input Edge Rate (AV/At)
"ACT Devices
VN from 0.8V to 2.0V
Vce @ 4.5V, 5.5V

—40°Cto +85°C
55°Cto +125°C

125 mV/ns

125 mV/ns
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AC Operating Requirements & Electrical Characteristics (ACT)

AC Operating Requirements for ACT
Vee Ta=+25°C Ta=—A40C to <B5°C
Symbol Parametar V) Cy =30 pF Cy =50 pF Units
{Mote 10) Typ Guaranteed Minimum
ts Setwp Tme, HEGH or LOW & 5 5 i
S 005, 0 P = ; ’ "
t Heodd Teme, HIGH or LOW 50 20 o 0 e
SporS, o CP = = 2
ty Setwp Teme, HEGH or LOW . o~ " 45
VO, 1o CP z e : ' s
ty Hodd Tame. HIGH or LOW 50 0 o 10 -
VO, to CF - N ’
1y Setep Teme, HIGH or LOW 5 T FE =
i o o ns
DSy or DG to CP
te Huodd Tame. HIGH or LOW i o D i
DS, or 05, 10 CP 2 e ¥ e
by CP Pulse Width 50 20 40 45 o
HIGH or LOW : g .
L MR Pulse Width, LOW 50 20 15 a5 ns
v Recovery Time, MR to CP 5.0 0 1.5 1.5 ns
Note 102 Voltage Range 5.0k 5.0V + 0.5V,
AC Electrical Characteristics for ACT
Voo Ta=+25°C Ta=-40°C to +85°C
Symibol Parameter vy Cy =30 pF Cp =30 pF Units
[Note ) Min Typ Max Min Max
Fram Maximum Input Frequency 5.0 120 170 110 MHz
ta Propagation Delay & i
50 40 a5 125 30 140
CP to @ or @, {Shift Left or Right) = =
b F¥ppeagabon Dicky 50 40 8.0 135 35 150 .
CF to Oy or @5 {Shift Left or Right)
e ErREon Dy 50 45 a5 125 45 125 ns
CP to /0,
ter fmagaton Detey 50 50 B.5 150 45 165 ns
CF to M0,
- P_mp ion Dtay 50 40 140 15.0 410 18.0 ns
MR to Qg or Oy
et Propagation Delay o . .
bkt | 4 13 4.5 a5 75
W to 10, 0 o i 1 ns
w2 e 5.0 25 a0 120 15 130 ns
OF to VO, ) ] ) ’ )
tez Cutput Enabie Time
Easley 50 20 an 120 15 125 -
OF to V0, .
tenz i 50 20 5 125 20 125 nz
OF to IO,
ez el e 50 25 an 1.5 20 125 ns
OE to VO,
Hote 3 ".-'Lzllaage ﬁ.z'lgs 5.0 s 5.0V £ 05V
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1. Exercise: 74ACT299 — Test patterns for functional test

Referring to the truth table, fill missing instructions in the right column and complete the test vector
columns for each pin when necessary (remember that no empty entries are allowed).

M | CP |[SO |S1 |DS|DS|IO [IO |IO (IO |IO |IO |10 |0 |Q |Q INSTRUCTIONS

R 0 7 0 1 2 3 4 5 6 7 0 7

0 1 0 0 1 1 1 1 1 1 1 1 1 1 X X Reset

1 1 0 0 1 1 L L L L L L L L L L Hold

1 1 1 1 0 0 1 0 0 0 0 0 0 0 H L // Load 10000000

1 1 1 0 0 0 L H L L L L L L L L

1 1 1 0 0 0 L L H L L L L L L L

1 1 1 0 0 0 L L L H L L L L L L

1 1 1 0 0 0 L L L L H L L L L L

1 1 1 0 0 0 L L L L L H L L L L

1 1 1 0 0 0 L L L L L L H L L L

1 1 1 0 0 0 L L L L L L L H L H

1 1 1 0 0 0 L L L L L L L L L L

1 1 0 1 0 1 L L L L L L L H L H Shift left 1
Shift left 1
Shift left 0
Shift left 0
Shift left 0
Shift left 0
Shift left 0
Shift left 0

1 1 0 0 0 0 H H L L L L L L H L Hold
// Load 10101010
Hold
Shift right 0
Hold
Reset

1 1 1 1 0 0 1 1 1 1 1 1 1 1 H H // Load 11111111

1 1 0 0 0 0 H H H H H H H H H H

1 1 1 1 0 0 0 0 0 0 0 0 0 0 L L

1 1 0 0 0 0 L L L L L L L L L L
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2. Exercise: 74ACT299 - Values for parametric tests

Referring to DC electrical characteristics, extract the value guaranteed in the datasheet for the
following parameters. Indicate whether it is a minimum or a maximum guaranteed value.

Datasheet guaranteed value

Test Conditions:
T=25°C and Vcc=4.5V

Min or Max?

Vil = -

Vih = -

Vol = with iol=24mA
Voh = with ioh=-24mA

Referring to AC operating requirements and electrical characteristics, extract the value guaranteed in
the datasheet for the following parameters. Indicate whether it is a minimum or a maximum

guaranteed value.

Datasheet guaranteed value

Test Conditions:
T=25°C and Vcc=5V

Min or Max?

Setup time I/O vs CP =

Setup time DSO/DS7 vs CP =

Setup time SO/S1 vs CP =

Hold time 1/O vs CP =

Hold time DSO/DS7 vs CP =

Hold time SO/S1 vs CP =

Propagation delay I/O vs CP =

Propagation delay Q0/Q7 vs CP =
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TESTER

.PART 2: v

ELEMENTS

FIRST STEPS WITH SMARTEST: PART 1

Step 1: Launching SmarTest

1/ Open the VNC icon \/n
C

VNC Viewer

Ask the teacher your login and refer to the following table to get your password, the VNC display
number and the default machine M to use for offline connection.

Login Password Y: VNC M: Default machine for offline
trainXv93 #trainXvo3# display connection
number

trainlvo3 #trainlvo3# 71 verigyon2016
train2v93 #train2vo3# 72 verigyon2016
train3v93 #train3vo3# 73 verigyoff2017
train4v93 #traindvo3# 74 verigyoff2017
train5v93 #train5vo3# 75 verigyoff2017
train6v93 #trainbvo3# 76 verigyoff2017
train7v93 #train7vo3# 77 verigyoff2017
train8v93 #train8vo3# 78 verigyoff2017

2/ Use this information to fill the VNC Connect window: M.cnfm.fr:Y
with M = verigyon2016 OR verigyoff2017

[ JON | VNC Viewer
vNC CoNNeCT [ ]

Once the connection established, according to the machine you connected, you should get one of the
2 following windows.
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Screen of verifyoff2017

ADVANTEST

© 8 2 g trenv3 Sgveripror - i e T : 10se
V8L 5. ‘ w2 MDD ERE S pull e e

3/ From the start menu « ‘ » (also called RedHat menu), the shortcuts to launch SmarTest® are
located in the menu “Verigy” or “Advantest”.

&2 Accessories
<& Games

h Graphics

@ Intemet

& Office

@ Preferences

% Programming
) Sound & Video
1) System Settings
Jg System Tools

“Online” mode
available only on
VerigyON

ﬁ SmarTest Online Documentation ‘

v ¥ v v v v v v v v

Control Center

é ::d Files gSmaﬂesl offline . “Offline” mode
B nep L] hp93000 .

(@) Home kill SmarTest To be used
% Run Command... Kkill hp93000 by default

G Lock Screen n switch Version

@ Logout “demo”...

When starting SmarTest®, you will have displayed a window called Workspace Launcher window.
Select Ok if you have the following path: /home/trainXv93/workspace_ MONTPELLIER; otherwise
“Browse” through the directories to access it.

B workspace Launcher = 1

Select a workspace

SmarTest Eclipse Workcenter stores your projects in a folder called a
workspace.

Workspace: [/home/trainiva3/workspace_MONTPELLIER [~ ]| Browse..

NEVER|SELECT
THIS QPTION

# [] Use this as the default and do not ask again

[ OK l [ Cancel ]

Never save your test program under this path. This is not the expected test program directory. It
will induce errors.
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When launching SmarTest®, 3 windows appear on the screen:

e« Operation Control » window allows controlling tasks execution on
tester.

E engineering I

Used to format datalog stream results.

il Execute Workorder
7 Supervise
1 Quit

] Production
Settings

I0LE

e « ui_report » window allows following the communication between the tester and SmarTest®.
It is very important to regularly look at this window to verify if any error or warning messages
appear.

¥ ui_report.ORG.PROD -0X
File Options Help HMode Datalog

99

Tester State |mscomscrsn (OFFLINE)

Tester Operation INOT nonitored (DISABLED)

Dev_license_file: None, model file used for licensing

INFO: (dataformatter) Starting dataformatter version 1,1,11 Nov 22 2007 20:47:41

INFO; (dataformatter) Log file /users/latorre/datafornatter,log initialized,

INFO: (dataformatter) Using global config file: /etc/opt/hp33000/soc/datalog/global,co
INFO; (dataformatter) Using STOF config file: /etc/opt/hp33000/soc/datalog/formatter,s
Loading will be done through import filter '/opt/hp33000/soc/com/1bin/hp83_import'
Prior to save '/opt/hp393000/soc/con/1bin/hp83_presave' will be run

j | >

Report Formatter | ,default,PROD
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e « SmarTest Eclipse Workcenter » window where the users will find all tools to develop a test

program.
B setup - SmarTest Eclipse Workcenter - /home/jspreux/workspace_6.5.4 -~ 3] %
Fle Edit Navigate Search Project Run 93000 Window Help
o @ % srorar |2 o xe » s> & >
B TestPro & (& Project | = O = O || Prope 2 .85 outin | < O
/Mome/jspreux/devices/CW_Lab < e -
= [ Device Information = Property Value
& <Test Program device /home/jspreux/des
b & <Pin Configuration.. > path
n saved true
n-
i -
< - t
& <Analog
% <Routir
8 <uUser f
$é <
| <7 -
= ttribute
< [ Testrioor Information
“ _Ap t
% <Applica Data
@ <warer > |
I D) I »)
[£ Problems 22 &4 Firmware 3 = =0 Console £ 9] Error Log = =)
0 errors, 0 warnings, O infos System ® = % bf | ™ B s~
Description Resource Path Location Starting s::n;:;';ox(iﬂ;:-’ f-v -
SmarTest WorkCenter Ready!
INFO: using location for configuration data specified in $HOME/.93KE
configuration_base=/tsp
I »)
ne £ Testriow

Step 2: Creating SmarTest Device directory

From the tool bar of the “Smartest Eclipse Workcenter” window, select 93000/Device/New Device;
from the opened window, browse the path /home/trainXv93/M2_xxx/ and enter the name 74ACT299
to create the new test program directory (refer to picture below).

BT window  Help K4 New Device o|x

Setup 4% Setup new device
Results * | @ Nodevice path specified
Debug ] —
Memory Test > [<] Change to new device after creation
Scan > Device path: €| /homeltrain1vO3/M2/74ACT299 > -
Analog >
Production o Device technology: lcmos v
System > Licensing file: lLlcensmg file cannot be selected at device creation
De @ New Device [[] v3 delay adjust [] Fast bidirectional capability
Ul updates suspended! #& Change Device... i o
Connect
£ PPU tester model: lact ll]
) Disconnect
. Break MCD Device cycles: - Waveform sets: 16 \ Timing sets: 256

Level sets: [32 PDC sets: DPS sets:
M sets: |32 Routing sets: |32 \ Testpoints: |0 |

["] RFI to RFE compatibility mode
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Return to the RedHad menu and open a “Terminal” window from “System Tools”.

Type the following command to access to your device directory:
> cd /home/trainXv93/M2_xxx/74ACT299
> Is (to see all the sub-directories automatically created)

EdShe
Session Edit “iew Bookmarks Zettings Help

a1

[trainlvasd/erigyOFF2 7442T293]% |s =]
Testhvethod data_set memt_| |apg scan_res timing

analog_control di_report memt_patterns scrartbling timing_dgrm

applicat error_rmap memt_repair shimoo vectors

hitmap fai | memory pin_attributes state |ist wafertyp

hitmap_conf format profiles testf|low waste

cal ihration levels report testf|low_vee waveform

ch_attributes | icense routing testfunc

configuration lock_file scan testprog

[trainlvaad@verigyOFFz 7442729915 [

Reminder: Procedure to exit SmarTest and VNC
- Exiting SmarTest: click “File > Exit”

- Exiting VNC: click on the cross [X] (DO NOT LOGOUT!)

FIRST STEPS WITH SMARTEST: PART 2
Now, you are going to setup the basic elements: PINS, LEVELS, TIMING, PATTERN.

Step 1: PINS

Depending on the progress of the course, the pin configuration will be either created by the trainees or
given by the trainer.

To copy an existing pin configuration file:
e OPEN a terminal window.
o Type the following command:

> cp /home/trainer/74ACT299/INIT_FILES/pins_103
/home/trainXv93/M2_xxx/74ACT299/configuration/.

e From the Test Program Explorer window on SmarTest, select the “Pin Configuration” grey item
(grey means not loaded). From the right click menu, load this “Pin Configuration” file.

M2
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* 93000 Setup - SmarTest Eclipse Workcenter - thomeftrain1v83/workspace ALGODONE -

m

Eile  Edit Navigate Search Project 93000 Run Window Help
EN TGS O BRI -2 Y T UE RS e
7| 93000 Setup

|EFE Test Program Explorer S@\\Nav!ga{or} 5 El“ il
fhomeftrainlv93/ALGODONE/74ACT 200 - ||
[E = R Selectfile toTo
A fi\jDevice Information
= ‘ New Folder | Delete File | Rename File ‘
- < Program...>
Eo <Test Flow...> ‘ [homejtrainlv93/ALGODONE/74ACT 299/configuration ¥ ‘
b Folders *! |Eiles Rad
- ; ] pins_103
Iﬂ,‘.Tmunq > i
ot <Pattern...» e
< <Pin Attributes...> B %
g
L =
g 1> hd
j, . Selection: /homejtrain1v93/ALGODONE/74ACT 299/configuration ; I,
B <User Procedure...> | gE| M B~ =0
D <Profile...>
= [ Testfloor information ‘ % Cancel | | ¥ oK | -
“% <Application Data
afer.. =
. INFO: createDefaultProfiles(): Created 'profiles' subdir of device for profile suppo
<Execution Input..,> " |||SmarTest WorkCenter Ready! 5
<Prober/Handler...> .
Data Bridge...> = e
_ = [=])|[<] e 7]

n & Pin Configuration

Have a look at the pins and pin groups setup:

4 93000 Setup -

fig SmarTest Eclipse YWorkcenter fhomeftrainivaamiorkspace 5T ROUSSET

File Edit Navigate Search Project 93000 Run Window Help
B TN O - e T TS
F5| ' 93000 Setup
H Test Program Explorer 2 \\Navlgator| =0 =g
fhﬂmeﬁ!a]nva]ISTjOUSSETIF?‘l:ACTZQQ —V N
BE R site : |1 ;_| of |1 CONTEXT: .
< [ Device Information B Pin No Pin Name Mode Type DUT Board Tester Channel Rad
& <Test Program...>
ii “Test Flow...> 1 12 CP std i 0.0 10302
i @ pins 2 18 D57 std i 0.0 10308
3 11 Ds0 std i 0.0 10301
b G Groups 4 19 51 std i 0.0 10309
b & Ports B 1 50 std i 0.0 10310
ﬁ«TCQre llocsiEn 6 9 _MR std i 0.0 10316
6?' DPS Channel Mode 7 17 Q7 std o 0.0 10307
b G Utlity Purpose # 8 8 Qo std o 0.0 10315 i
ﬁ ebevels. 9 16 Iyo7 std io 0.0 10306 22
H-'Tlmlng 5 10 |4 /OB std io 0.0 10311
B Pattern...> 11 15 IfO5 std io 0.0 10305
e A 5 12 s 1/04 std io 0.0 10312
@ <Test Control,..> 13 |14 1/03 std io 0.0 10304
& <Analog Contral...> 14 6 o2 std io 0.0 10313
L 15 13 IfO1 std io 0.0 10303
Be<Routing.. > | | 16 7 Ifoo std io 0.0 10314
EG l Procedin: s 7 Voo DPS+ 10.0 DPSI1
$ <Profile...> M
7 [ Testfloor Information Py i ¥
B} ~annlicatinn Pata
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Step 2: LEVELS
Repeat the operation for the levels:
e Copy an existing levels file to your device level directory with the command:

> cp /home/trainer/74ACT299/INIT_FILES/levels_74ACT299
/home/trainXv93/M2_xxx/74ACT299/levels/.

e Return to the Test Program Explorer and load the levels:

1. From the Test Program Explorer, select “levels” item
2. From the right click menu, select “Load”
3. From the “Select File to Load” window, select “levels_74ACT299"

e Open the Level Setup window from the level item in the Test Program Explorer (« open » from the
right-click menu or double-click). Displayed values are defaults values.

From the menu “Select” of the Level Setup window, choose “Show 1/0 Eqn & Specs Results” to display
the levels that will be applied to the device as specified by Eqn#, Sps# and Lset#.

[ Level Setup
Select Edit Doc Format

IJ Lset# [I} of 1 Level |no termination

Equation [no equations o

. VOV
7.000

Edit Specifications
Edit Equations

You can access to the list of existing Eqn#, Sps# and Lset# from the menu “Select->Select
Specification...” and choose the one you want to display.
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', Selectspecification)

ORS puerup) tage

Show I/0 Eqn. & Specs Results
Show FAST Eqn. & Specs Results
Show DPS Fon. ¢ Soecs Results

Edit Speciticarions
Edit Equations

> Filter :

To understand how these values have been programmed:
- Choose “Edit Equations” from the menu “Select” to open the Level Equation Set Editor; look
at the defined EQNSETs and LEVELSETSs.

= /var/opt/hp93000/soc/tmp/93k.VsQyEO/edit Iviegn - O X
File Edit Search Preferences Shell Macro Windows Help |
Al <] 4 Rev _f RegExp .1 Case
/var/opt/hp93000/s0c/mp/93k VsQyEO/edit_Iviegn 1398 bytes Ty (ehiees

:Il% EQNSET 2 "with specs" =

73

74 SPECS

75 VCC [V] #supply voltage

76 VIL [V] #low level input voltage

77 VIH [V] #high level input voltage

78 VOL [V] #low level output voltage

';(9) VOH [V] #high level output wvoltage

81

82 DPSPINS Vce

83 vout=VCC

84 i1imit=1000

85t ms =4

gg offcurr=act

gg LEVELSET 1 "no termination"

90 PINS ctrl ser_in
91 vil =VIL

92 vih =VIH

93

94 PINS ser_out

95

96 vol= VOL

97 voh = VOH

98

99 PINS io_pins

100

101 vil = VIL

102 vih = VIH

103 vol = VOL

104 voh = VOH /
~J 1=

M2
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Choose “Edit Specifications” from the menu “Select” to open the Spec Tool; look at the Spec
Variables and their values for the different SpecSets.

Use the menu “Select” of the Spec Tool to choose among the list of existing specifications
with their description the one you want to display in the Spec Tool.

| selectspecification O X

Regular Expression Filter
I

Egn Sps Description

X Speclool

2 1 Vccnom - relaxed levels
2 2 Vecemin - relaxed levels
2 3 Veccmax - relaxed levels
2 4 Vcc=5.5V - relaxed levels

Equation [ 2 with specs

Name Actual Minimum Maximum  Measured

select filter cancel

Using the tools/editors available in SmarTest, find the information to fill in the following table.

Eqn Spec Lset supply all_in all_out

# # # DPS value Drive values Compare values
low high low high

2 1 1

2 2 1

2 3 1

Are these levels appropriate to implement functional tests? Justify your answer.
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15/35



Step 3: TIMING
Repeat the operation for the timing:
e Copy an existing timing file to your device level directory with the command:

> cp /home/trainer/74ACT299/INIT_FILES/timing_74ACT299
/home/trainXv93/M2_xxx/74ACT299/timing/.

e Return to the Test Program Explorer and load the timing:

1. From the Test Program Explorer, select “timing” item
2. From the right click menu, select “Load”
3. From the “Select File to Load” window, select “timing_74ACT299”

e Open the Timing Setup window from the timing item in the Test Program Explorer (“open” from
the right-click menu or double-click).

Select “DISPLAY->DOUBLE” to enlarge the window.

Create an appropriate format to visualize the waveforms for the different types of pin:
- from the menu “Format”, choose “new”
- define a format that contains CP, _MR, mode, ser_in, ser_out, io_pins
- unselect the box “show same device cycle for all pins”
- save your changes

M2
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R4 Timing Setup ; i ;
Select Edit DevCycEdit Check Doc Display Format

Ean#[ 1 | Sps#[L | Teet#[ 1 | of 2 Port:ll DRG]

—_—

Equation e
te - Define format -

Timing

The Timing Setup window now shows one waveform for each pin or pin group defined in the format,
as specified by Eqn#, Sps# and Tset#. If it is not the case, choose “Show Eqn & Spec Results” from the
menu “Select” and fill the device cycle name you want to display for each pin or pin group in the
“DevCyc” column.

To see all the waveforms defined for a given pin or pin group, click on the name of a pin or pin group
and choose “One pin” from the menu “Select”. It will show you all the defined waveforms for the
chosen pin or pin group.

To see again all pins or pin groups, choose again “format pins” from the menu “Select”.

To see the values of edge location for a given pin or pin group, click on the name of a pin or pin group
and choose “Edge delay” from the menu “Select”. It will show you the value of defined edge delays
for the chosen pin or pin group.

Note: You can access to the list of existing Eqn#, Sps# and Tset# from the menu “Select->Select
Specification...” and choose the one you want to display.

To understand the waveforms displayed in the Timing Setup window:
- look at the waveform table (“edit wave tables” from the menu “Select”)
- look at the definition of edges location (“edit equations” from the menu “Select”)
- look at the values of the spec variables (“edit specifications” from the menu “Select”)
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Using the tools/editors available in SmarTest, find the information to fill in the following tables
for Eqn #1, Spec #1, Tset #1.

Activation time End time

CP
Mode
Ser_in

Capture time

Ser-out
10

Is this timing appropriate to implement functional tests? Justify your answer.

Step 4: PATTERN
Repeat the operation for the pattern:
e Copy an existing pattern file to your device level directory with the command:

> cp/home/trainer/74ACT299/INIT_FILES/ pattern_74ACT299
/home/trainXv93/M2_xx/74ACT299/vectors/.

e Return to the Test Program Explorer and load the pattern:
4. From the Test Program Explorer, select “pattern” item
5. From the right click menu, select “Load”
6. From the “Select File to Load” window, select “pattern_74ACT299"

From the Test Program Explorer, double-click on “pattern_74ACT299” to display the pattern list in Test
Pattern Explorer window.

For this example, the pattern list only contains 3 patterns.
Double-click on the pattern called “funcl” and look at the detail of this pattern in the Pattern Editor
(you should recognize the pattern from the first exercise).
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VM
SM

Main
Main

| Type

]Pon

Exiting VNC: click on the cross X1 (DO NOT LOGOUT!)

Exiting SmarTest: click “File > Exit”

i func_spec_search

Name
A func

Reminder: Procedure to exit SmarTest and VNC
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PART 3:

QUESTIONS ABOUT FIRST TEST CONCEPTS

Answer to the following questions relative to the test concepts.

Continuity test
What is the purpose of this test?

What is the voltage applied on Vcc and device pins? Why?

The measured voltage on a given pin is 0.004V. What does it mean for this pin?

The measured voltage on a given pin is 2.0V. What does it mean for this pin?

Functional/Structural test
What are the voltages applied on inputs for low and high levels in case of a relaxed functional test?

What are the comparator threshold voltages typically used for interpretation of low and high levels in
case of a relaxed functional test?

What are the main differences and similarities between structural and functional test approaches?
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PART 4: e

TEST PROGRAM DEVELOPMENT: FIRST TEST FLOW

Step 5: Create your first test flow

From the Test Program Explorer (Setup Perspective), select the “Testflow” item. To create a new test
flow, perform the following actions:
e From the right click menu, select “New”.

e Enter the testflow name “first_flow” and click “Finish”.

[E;Proje:tEx‘H 2\ =0
/mnt/share/Training_FirstSession_12- <«

@ Right-click on testflow
item & Select ‘New’

« [, Device Information
& - Test Program...>

[ TrainingFlow

b & pins_soc
X levels Create testflow —p
A\ timing Enter testflow name
4% all binl ———=
<Test Control...> —
Location:

<Waveform...>

h's
%]
%- Anajog Control...>
.
% @ Enter name of

<Routing...>
8 <User Pv‘m edure...> new testflow
$ <Profile..>
[ <Test Table...>
. <Channel Attributes
b [ Testfloor Information 9 Click ‘Finish’

D [ Test Results

@ [ Finish 'H Cancel ]

e From the right click menu on the Testflow item, select “Open with > Flow Sequence Editor”.
An empty flow is opened in the flow sequence editor.

@ Right-click on testflow item ~ SefrstFlow & =

& Select ‘OpenWith -> >
Flow Sequence Editor’ Il

(% Project Explore
/mnt/share/Trainng_6-5-4/my_74ACT299

- Palette

< [ Device Information

- Empty flow

(OFlow Sequence Editor ’

Open Testflow To Merge ... (@ Flow Data Editor
Show In Project Explorer ‘
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Step 6: Setup the context

The next step is to setup the context, i.e. to specify the pins, levels, timing and pattern that will be
associated to this test flow. For this, perform the following actions:

e Right-click in an empty zone of the testflow window and select “Open > Setups Page”.

e  Fill-in your primary files in the corresponding setup entry (pins_103, levels_74ACT299,
timing_74ACT299, pattern_first_flow).

P FirstFlow £3
% | % .
T ArstFlow &3 =g
o Setup File
3
®
o
I8 Run Testflow Ctri+T
RUn »
E o|| variables Page  ctrivaitr,
Flags Page Ctri+Alt+.
Insert E
Insert Floating Test Suite Ctri+l Setups Page Sk

Collapse All
Expand All

Preferences... Test Suites Parameters Tests Bins Variables Flags Setups|Information

e Return to Test Program Explorer, select the “Testflow” item and select “Load All Setups” from
the right click menu.

Step 7: Insert Testsuites

Now you have to insert a test block for each test you want to perform. For this first test flow, you have
to implement 4 tests:

- acontinuity test

- a functional test @Vccmin
- a functional test @Vccnom
- a functional test @Vccmax

To insert a new Testsuite, perform the following actions:
e Choose the insertion point and select “Insert > run and branch” from the right click menu
e Fill in the required information and click “Finish”.
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Fa FirstFlow 53 Elfed

3 5 New “Run And Branch” Node
@ The Test Method field must not be empty.
© select I
i nse rti on e Test Suite Name | continuity
4 ® H 3
point g (2] Right-click or Open Palette Commegt
‘ P, s
& Select ‘Run and Branch’  mstmetnoa )
[} select | Timing Equation J
¢)Ru" Test Waveform Set N
@ Run and Branch g - e
iming Se |
¥ Good Bin 2
. Bad Bin o || Level Equation |
ﬁMultl Bin i DPS Set |
@I Print Level Set .
€8 Print to Datalog Analog Set
@ If/Then Pattern
dFRepeat Loop :
& While Loop Context [oeFauLT
@ For Loop
#2 Assign Value
832 Assign Level Value
&3 Assign Timing Value 2 Cancel

Details on the required information for continuity and functional test blocks are given herafter (choices
for timing and pattern information are given but you have to make the appropriate choices regarding
level information for each test block — refer to Exercise: Basic Elements — Levels in STEP 2).

Continuity test
TESTSUITE FIELDS VALUE

Testsuite name Continuity

Test Method select “dc_tmI>DcTest>Continuity”
Timing Equation 1

Timing Spec Set 1

Timing Set 1

Level Equation Choose the appropriate Level Equation
Level Spec Choose the appropriate Level Spec
Level Set Choose the appropriate Level Set
Pattern “funcl”

Functional test
TESTSUITE FIELDS VALUE
Testsuite name
Test Method

Functional_Vccmin/nom/max
select “ac_tml > AcTest > FunctionalTest”

Timing Equation 1
Timing Spec Set 1
Timing Set 1
Level Equation Choose the appropriate Level Equation
Level Spec Choose the appropriate Level Spec
Level Set Choose the appropriate Level Set
Pattern “funcl”
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Step 8: Insert Bins

You have now to insert a bad bin in the failing branch of each test block and a good bin at the end of
the test flow according to the information given in the following table.

SOFT
INSERTION SOFT BIN HARD
BIN TYPE POINT BLN NAME BIN # HARD BIN NAME
CONTINUITY FAILED
BAD Failing Branch 2 CONTINUITY 2 CONTINUITY
FUNCTIONAL Vcemin FAILED
BAD Failing Branch 3 FUNCTIONAL Vcecmin 3 FUNCTIONAL
FUNCTIONAL Vccnom FAILED
BAD Failing Branch 4 FUNCTIONAL Vccnom 3 FUNCTIONAL
FUNCTIONAL Vcecmax FAILED
BAD Failing Branch > FUNCTIONAL Vccmax 3 FUNCTIONAL
FUNCTIONAL Vccmax
GOOD Passing Branch 1 PASS 1 PASS
(end of test flow)

To insert a new Bin, perform the following actions:
e Choose the insertion point and select “Insert > Good/Bad Bin” from the right click menu.

e Fill in the required information and click “Finish”.

Step 9: Define parameters and limits

You have to setup the test conditions and limits of your continuity test block according to the following
information.

Field Value Comment
pin list @ all pins

test current =50 uA

pass volt min 200 mV

pass volt max 800 mV

settling time 4 ms
measurement mode PPMUpar/ProgLoad (your choice)
polarity SPOL/BPOL (your choice)
output ReportUl

Practically to setup the test conditions and limits of a Testsuite, perform the following actions:
e Double-click on the Testsuite in the Test Flow Editor; the Properties View opens.

e Inthe Properties widow, unfold “Test Methods” (see figure herafter)
o Unfold “Parameters” and replace default values by yours.
o Unfold “Limits” and replace default values by yours.

Caution: Do not write the units when entering values.
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Fa my _first_flow &3 = 0| [ Properties £ 5= Outline 5 /| Y =0

type filter text

A Property Value -
g " < Test Method dc_tml.DcTest.Continuity
: v Parameters
1 pinlist @
testCurrent -50[uA]
O settlingTime 4[ms)

measurementMod:  ProgLoad
polarity BPOL
prechargeToZerov ON

T
Functional Vccnom

T
Functional Vccmax testName passVolt_mv
Y output Reportul
< Limits

v passVolt_mv
Test Number

Limit Value 200 <= v ) X|<= - /1800

< Flags

Functional test block takes no test conditions and no test limits (except the pinlist), so you don’t have
to change the default values.

Cl Properties £3
‘type filter text
Step 10: Flag setting and test execution (offline) ooty AL
The final step before test execution is to set flags for each Testsuite to T
specify which results will be displayed in the Ul-Report window. Test Level 0
Bypass O
i . X X Set pass d
For this, go to the Properties view of each Testsuite, unfold “Flags” and Setrail o
activate the following options: Hotd 0
Hold on fail O
OUtPUt on pass Output on pass vl
- Output on fail Outpution/fall <
Pass value vl
- Passvalue Fail value %
_ Fa|| Value Per pin on pass )
Per pin on fail %)
- Per pinon pass Force serial 0
_ . . Log Mixed Signal Wavefor [_]
Per pln on fall Fail per label O

The tests are now ready to be executed. You have 2 options from the Testflow editor:
1. Select a Testsuite and choose “Run Selected” from the right click menu. Only this test block
is executed.
2. Click on any zone of the test flow and choose “Run Testflow” from the right click menu. The
complete test flow is executed.

Try both these options and look at the Ul-Report window to make sure you have no syntax error and
to visualize the displayed results. (Clear the Report window before each execution).

Note: In the offline mode, the Continuity test fails in PMU mode (while it passes in PL mode), because
the simulator returns 0 value for the measured pin voltage. To execute the complete test flow despite
this fail, activate the Flag “Set Pass” of the continuity test in the Properties window. You should obtain
a Pass when running the complete test flow.
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Your first test flow is now complete and ready to be verified online. For this, quit the simulator mode
and connect online to the tester.
Do not forget to disable the Flag “Set Pass” of the continuity test before going to the online mode.

Step 11: Online test execution

NOTE: In case you developed your test flow on Verigyoff2017, due to compatibility issues you should
first copy a similar test flow developed on Verigyon2016. To do so, type the following command in a
Terminal:
> cp /home/trainer/74ACT299/INIT_FILES/first_flow_Verigyon2016
/home/trainXv93/M2_xxx/74ACT299/testflow/.

L

&2 Accessories

Ask the teacher the availability of the online license.
If OK, connect to the online machine verigyon2016 using |\ came

@ Intemet »
VNC. Keep the same login and password (cf. page 7 to oo
remember your password and VNC display number). o)

12 System Settings

J¢ System Tools

Once the VNC window is opened (purple background), i e oo v e
Find Files & smarTest offline

start the online license from the RedHad menu ‘: il

“Verigy >SmarTest” B Run Comman...

{7 Lock Screen
@ Logout *demo...
=

In the Test Program Explorer window, check that the test program path is vyours
(/home/trainXv93/M2_xxx/74ACT299). Otherwise, click “93000 > Device > Change Device” and select
the path relative to your test program.

From the Test Program Explorer, load your test flow (first_flow) and all the primary files (pins_103,
levels_74ACT299, timing_74ACT299, pattern_74ACT299).

Open your test flow in the Flow Sequence Editor and perform the following experiments:

1. Execute the complete test flow and verify you obtain a PASS.

2. Execute only the continuity test and look at the results in the Ul-Report window.
Return to the Properties window of the continuity test and change the “Polarity” in the
“Parameters” section. Execute the test and look at the results in the Ul-Report window.
Return to the Properties window of the continuity test and change the “MeasurementMode”
in the “Parameters” section. Execute the test and look at the results in the Ul-Report window.

3. Select afunctional test block and change the test pattern to “func2” in the Properties window.
Execute only this functional test (“Run selected”). What is the test result?
To understand the origin of the problem, open the test pattern “func2” in the Pattern Editor
(double-click on “func2”). From the menu Pattern, select Expanded Mode. Run again the
functional test and look at the results in Pattern Editor: failing vectors are highlighted in red.

Correct the values applied on the “mode” inputs (SO and S1). Run again the functional test.
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PART 5:

QUESTIONS ABOUT PARAMETRIC TESTS

Answer to the following questions relative to parametric tests.

Vil/Vih tests
What is the purpose of Vil/Vih test?

Observe the VIL/VIH measurements displayed in the table below.

PIN VIL VIH

DS7 1.500000 V 1.785000 V
SO 1.395000 V 1.825000 V
S1 1.455000 V 1.845000 V
_MR 1.435000 V 1.740000 V

According to the data sheet values, do you think these tests pass at T°=25C? Justify your answer.

Vol/Voh tests
What is the purpose of Vol/Voh test?

Referring to the datasheet, how many Vol/Voh tests should be implemented to exhaustively verify all
Vol/Voh specifications? List them.
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Setup and hold time tests

Do you agree with both definitions?
- The setup time is the maximum amount of time the data input must be held steady before
the activation of the clock.
- The hold time is the minimum amount of time that the data have to be present before the
activation of the clock.
If not, provide the correct definition.

Look at setup time measurements displayed in the table below.

PIN SETUP TIME
100 3.493000 ns
101 3.431000 ns
102 3.294000 ns
103 3.210000 ns
104 3.227000 ns
105 3.232000 ns
106 3.192000 ns
107 3.393000 ns

According to the datasheet values, do you think this test passes at T°=25C? Justify your answer.

Propagation delay tests
What is the purpose of the propagation delay test?

Do the following measurements meet the specifications?

PIN Prop delay
Q7 9.701000 ns
Qo 10.535000 ns
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IMPLEMENTATION OF PARAMETRIC TESTS on 74ACT299

In this lab, you will run a more thorough test flow that includes not only continuity and functional tests
but also some DC and AC parametric tests. The structure of the test flow will be provided.

The objective of the exercise is to define the test conditions and limits of the parametric tests
according to the device datasheet and to evaluate the actual circuit performances.

Note: to know which test conditions and/or test limits you have to change in each test block, return to
page 6 of this document and consult the values you have extracted from the data sheet

Step 1: Copy an existing test flow and its associated primary files (offline)

e Open aterminal window from the RedHat menu « ‘ ».
o Copy the test flow file called “full_flow_2Modify” to your “testflow" directory with the
command:

> cp /home/trainer/74ACT299/INIT_FILES/full_flow_2Modify
/home/trainXv93/M2_xxx/74ACT299/testflow/.
e Copy the pattern file associated with this test flow to your “vectors” directory with the

command:

> cp /home/trainer/74ACT299/INIT_FILES/pattern_full_flow
/home/trainXv93/M2_xxx/74ACT299/vectors/.

The levels and timing files used for this full_flow are the same than for the first_flow
(levels_74ACT299, timing_74ACT299).

Step 2: Modify the existing test flow (offline)

e Load the test flow from the Test Program Explorer and open it in the graphical editor (Flow
Sequence Editor).
e Load the primary files associated to this test flow (“Load all setups”).

You have now to modify the test flow in order to specify the correct test conditions and limits for the
DC and AC tests.

The modification of the values will be done in the “test contro
block. The procedure is the following:

e Select the first test block you want to modify.

III

window (yellow window) for each test

e Inthe Properties window, select “Test Function > Parameters” and press F3. This will open the
“test control” window.
e Change the default values by the values you have extracted from the datasheet.

IM

e Once the changes are done, close the “test control” window and move to the next test block in

the test flow.
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Pa Test2Complete 2 =a|m R 5= Outline |~ =0
. ' Bllfype firertex]
" Functional Property Value
g ] |¥ TestSuite VIL_VIH
< Comment ontro
< Primaries Edit Doc
b Timing al 51 Input Voltage
b Level 2,4,1 Sensitivity
P Analog 7
Pattern ross_func m : 3
e . pin list ES7.SO.51._MR
Context DEFAULT_—~
Test Type T
= Test Function /x"’/ vil_vih_tf | low | high
Parameters inp_volt_sensitivity; 057,50, pass level v I 0.8 | 2.00
P Flags
["]/ b site Control
= QO serial
- @ parallel
Please click "OK" after you finish editing parameters in Test Control
Window. output VIL/VIH ($P)

(@ETID)

i ACtests |

Practically, you have to modify the following test blocks:

- 1Vil/Vih test:
only Vil and Vih values matter.

- 1Vol/Voh test:
Vol/Voh + lol/loh values have to be

The test control block also asks low/high limits for PMU clamp voltage; enter OV and 5V

respectively.

- 3 setup time tests:
o DS0/DS7 (ser_in) versus CP

o 10][0:7] versus CP
o S0/S1 (mode) versus CP

- 3 hold time tests:
o DS0/DS7 (ser_in) versus CP

o 10][0:7] versus CP
o S0/S1 (mode) versus CP

- 2 propagation delay tests:
o QO0/Q7 (ser_out) versus CP

o 10[0:7] versus CP

Once you have modified all the test blocks, save the new test flow under the name “full_flow” (click

considered.

right on the test flow item in the Test Program Explorer and select choose “save as”).
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Step 3: Run the test flow (offline)

Run the test flow offline to verify that you don’t have any syntax error.

Note: In the offline mode, a Fail might be obtained at any of the parametric tests because the simulator
returns dummy values, and the test flow stops at the Fail result. In order to verify the syntax of the

entire test flow, you should permit the complete execution of the test flow.

For this, perform the following actions:

Look at the results in the Ul-report window. You should have two sections, the bottom section with
the global Pass/Fail result and the top section with the detailed results for each test block. Separator

Open the test flow in the “Flow Data Editor” (click right on the test flow item in the Test Program

Explorer and select “Open with > Flow Data Editor”).

Choose the “Flags” tab at the bottom of the window.

Search the “Global Overon” flag and change its value it to “on”. This will enable to continue the

execution of the test flow until the final bin, even after reaching a “Bad” bin.

| (& Project Explore i TestProgramE &3 . < 0O
|/mnt/share/Trainng_6-5-4/my_74ACT299 =

v [y Device Information

Open Testflow To Merge .. @Flow Data Editor

Flow Data Editor window

Show In Project Explorer o

Fe DC_AC_testflow [l DC_AC_testflow &2 =
’ Flags ali Flag Type | Value

22 0

23 off

24 on

25 |[globa off

26 0 (Debug off)

27 off

28 |parallel_mode on

29 te match mode auto(on)

W o> © on |

31 mits_enable on

32 on

33 1

34 1000000

35 off

36 0

37 0

a0 obucet s i TaCTE A ~FE
Test Suites Parameters Tests Bins Vanableetups Information

Return to the Flow Sequence Editor and run again the entire test flow. All test blocks are now
executed, i.e. they all have a Pass or Fail result (as indicated by the green/red color of each test block).

between the 2 sections can be moved from the small square on the right side.
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File Options Help Mode Datalog

EIIEAIC)

Tester State Inxmcm (OFFLINE)

Tester Operation [ NOT monitored (DISARLED)

VIL_VIH inp_volt_sensitivity FRIL  135,000000 mY  4420,000000 nY 110,000000 )
Test_number: 6
Begin_limit_data:
m 1&1,1,202001,202001
“DC_tests" = =
inp_volt_sensitivitysall_in; V:0,8:2,0:0:VIL/VIH ($P); TOP §ectlon.
Dind_;l-n.data FiNG [ vai 517 RN e I Detailed results
Be;:;‘-g:::t;;;:‘z. pin_name NUO [ valueO unit! NU1 [ valuel unitl for each test block
CP P 3375,000000 w¥ P 110,000000 Y
DSO P 4150,000000 wV F 2500,000000 nY
17 b $30:000000 w0 F 2iBoc000m  w raw data
1700 P 2605,000000 Wy P 975,000000 nY
1701 P 1240.000000 W P 725.000000  wY Ll
1/02 P 3185,000000 wY P 1175,000000 nY
1703 P 2105,000000 wY P 730,000000 nY
1704 F 135,000000 wY F 2395,000000 nY
1/05 P . 000000 Y F 2510,000000 Y
1/06 P 1145,000000 wY P 315,000000 nY
1/07 P 4010,000000 w F L0000 wY
SO P 2385,000000 wV F 4435,000000 nY
S1 P 4420,000000 wV 565, 000000 Y
/)

Separator

=] J /g_
{

Device test FAILED! Bottom Section:

oo 00000 @ e e S ootd Global Pass/Fail result
ereres @ ee @ @ oosens
eeeses 00000 00000 @ @ pOOOsNE
POGRORE+ e e @ @ ————-
woeres @ @ @ @ Qa0 e
-
/

5] ]

Report Formatter .default .PROD

If you don’t have the top section, perform the following actions:

Open the test flow in the "Flow Data Editor” (click right on the test flow item in the Test Program
Explorer, select “Open with > Flow Data Editor”) and choose the “Flags” tab.

Make sure that the flags “datalog_to_report_win”, and “datalog_formatter” and
“log_event_enable” are set to “on”.

Make sure that the flags “datalog_to_report_win”, and “datalog_formatter” and
“log_event_enable” are set to “on”.

R *DC_AC_testflow  [[[I*DCIAC testflow £3 . =
Flags I Flag Type ] Value =]
1 report_to_file SYSTEM on
2 report_to_printer SYSTEM off
3 datalog _to file SYSTEM on
4 datalog_to_printer SYSTEM off
» 5 datalog_to_report_win SYSTEM
» 6 datalog_formatter SYSTEM @
7 datalog_sample_size SYSTEM 1 -
8 graphic_result_display SYSTEM on
9 state_display SYSTEM off
10 |print_wafermap SYSTEM off
11 |ink_wafer SYSTEM off
12 max_reprobes SYSTEM 1
13 temp_monitor SYSTEM on
14 calib_age_monitor SYSTEM on
15 diag_monitor SYSTEM on
16 |current_monitor SYSTEM on
mp [17 [log events enable SYSTEM
18 stdf_generation SYSTEM on
19 |tm _crash_as_fatal SYSTEM off =

Test Suites Parameters Tests Bins Variables Flags Setups Information

Return to the Flow Sequence Editor and run again the entire test flow. You should now have the
two sections.
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Note: The default format used to display the detailed results in the Ul-report window is a raw format
that does not help to data readability.

To improve data readability, you can specify the use of a formatter with the following actions:
e Go to the “Operation Control” window. Click on “Production Settings”, then click on “Report
Formatter”, choose “EventFormatter” and finish with “Select”.

Ad Op on Control (NI=1E3
engineering | IIo
i Execute Workorder
Selection
I Supervise oo X
i Quit .default
o< I Production E
tti "E’
hdTe 0 e g ode

I IDLE ]
File
Testflow: | testflowl
1 System Flags

1 Testflow Flags =

=
4]

- User Flags

Filter | Cancel |

. Testsuite Flags

I Report Formatter e

Enter Prod. Settings Mode |

e Go to the “Ul-report” window. In the “Datalog” menu, choose “Enable Event Formatter”. Then
choose “Open Report Dialog”. For each test type (except the analog one), select “Passed Pins”,
“Failed Pins” and “Limits” (when available). Click on “Set Testsuite Flags” and finish with “Close”.

ui_report.ORG.PROD

=
File Options Help | Datalog | Log File
~ le Event Formatter
—@I —"] !I Disable Event Formatter
Tester State [n_ Open Report Dialog e :
Save current Formatter settings Report Dialog =l & ¥

Tester Operation IE' Load Formatter settings Test Types | FFV

Clear Bins ~Functional Test Te
wHRHRE production repo Output Testsuites that Output Testsuites that
Started at: 20220526 ot Testsuite Flags mRass  [FAIL
Testflow execution | Restore Testsuite Flags

e

wrakk @ ) [ [
Rk @ g @

BIN : 1 (PASS)
Ended at: 20220525 174121

AR
AoAAAAA
A

ik end testflow report data s

IXNFU: (dataformatter) Completed Detailed STDF file per Lot:

(5]

device : 7 ~Output as Result —Output_as Result
. |FF¥ ON/OFF between pins
DUT_path : Spces P 1 11 Passed Pins T Passed Pins
testflow ¢ DPrint Bin Statistics
userprocedure ¢ I Failed Pins U Failed Pins I Failed Pins
waakkkd begin testflow report data : *hdes N
U Limits N Linits
Device test PASSED! {J Waveforns
w00 0REEE QEERR *rrrex
R TR e P

User Procedures
=P GC—=—=pe Ot Uor Procedres

/home/azais/stdf /manual/main_Lot_1_May_

N

Report Formatter | EventFormatter

/
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Return to the Flow Sequence Editor and run again the entire test flow. Look at the detailed
results in the top section of the Ul_report window. The data are now much easier to read...

File Options Help Datalog Log File

(FIIEAIC )

Tester State IDIMCTED (OFFLINE)

Tester Operation Irm wonitored (DISABLED)

-------- Input Voltage Sensitivity High: FRILED
Pass/Fail Limit: 2,000000 V (Less or equal means passed)

Measured Range: [ 0,300000 V ,, 4,365000 V]

-------- Pin Results

CP FRILED

DSO FAILED

DS7 PRSSED

1/00 PASSED

1/01 FRILED

1/02 FAILED

1/03 PRSSED

1/04 PRSSED

1/05 FAILED

1/06 PASSED

1/07 PRSSED

SO FAILED

S1 PASSED

MR PASSED

Top Section:
Detailed results
for each test block

formatted data

;

CcCcCcCcCcC<cCcCcC<c<c<c<c<<

-

il

:

===z=z=== Ended Testsuite VIL_VIH

“| separator

N 5
Device test FRILED!

e m R -
wrears @ 999 S S s Bottom Sectlon‘:
weeer 00000 @EOOQ @ @ [ Global Pass/Fail result
L 9 Q 0 9 0 EE R
@  eeeee

sarane

R '] e e

BIN : 6 (FAIL VIL_VIH)
Ended at: 20220713 103759

N =

Report Formatter | EventFormatter

Once all these steps are accomplished and everything is ok, your testflow is ready to be executed
online. Quit the offline license. Do not forget to disable the Flag “Global Overon” in the Flow Data
Editor before going to the online mode.

Step 4: Run the test flow (online)

e Connect to verigyon2016 and launch the online license.

e Load your test flow, open it in the graphical editor and load the primary files associated to this
test flow (“Load all setups”).

e Execute the test flow.

e Look at the global Pass/Fail result in the bottom part of the Ul-report window. You should obtain
a Pass!

e Look at the detailed results in the top part of the Ul-report window. If data are not correctly
formatted, repeat the procedure described in the preceding page to specify the use of a
formatter and run again the entire test flow.

e Save the detailed results given in the top section of Ul-report window in a text file (click in the
top section and then click on menu “File > Save”) and quit the online license.
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Exercise: 74ACT299 — AC_DC_testflow — Test Results

From the analysis of the detailed results saved in the text file, write in the following table the worst-
case values observed over the tested pins for each measurement. Evaluate the corresponding margin
based on the datasheet information.

(Measured Value + DS Limit) §

Margin (%) = DS Limit

100

Datasheet

M remen Worst- val
easurement orst-case vallie guaranteed value

Margin (%)

VIL

VIH

VOL

VOH

Setup time
Ser_into CP

Setup time
10x to CP

Setup time
Mode to CP

Hold time
Ser_in to CP

Hold time
10x to CP

Hold time
Mode to CP

Propagation delay
CP to Ser_out

Propagation delay
CP to I0x

Looking at these results, what can you say about the device?
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